// Frontera Technical Support • View topic - Inditcators not working
   
 

Inditcators not working

banter general discussions etc

Inditcators not working

Postby rosieposie on Mon Jul 29, 2019 9:54 am

Help please, I have a 1998 2.2TDI Frontera. The Indicators stopped working yesterday complete with the Hazard warning lights. We swopped the instrument cluster this morning as we have had to have that repaired so happened to have a spare - swopping it has made the Hazard warning lights come on but not the indicators. With the previous cluster in at was shorting the fuse for the indicators before the ignation was turned on?
At the same time the demister, Air Con and Electric windows are also not working.
Any thoughts?
The cluster repair people are suggesting that the Indicator Hazard relay has blown? Could the one controlling the demister/ windows have also blown?
rosieposie
Newbie
Newbie
 
Posts: 2
Joined: Mon Jul 29, 2019 9:23 am
Region: Midlands



Re: Inditcators not working

Postby stretch on Mon Jul 29, 2019 3:32 pm

Hi yes best place to start is fuses and relays, do you have an owner's manual?
User avatar
stretch
Rain cloud of doom
Rain cloud of doom
 
Posts: 3159
Joined: Wed Jul 18, 2007 3:26 pm
Location: Ipswich
Model: 2.2 DTI 5dr
Registration Year: 2000/W
Vehicle Name: F.I.T.T
Modifications: 12v feed in boot
Truckputer under construction
Front & rear recovery points
De side stepped
Region: East Anglia



Re: Inditcators not working

Postby rosieposie on Mon Jul 29, 2019 4:34 pm

we have just got some fuses/ relays out of a scrap one as they are now obsolete. We have replaced all of the relays and still nothing.
owners manual is not helping
strangely we think we have taken out the fuse for the Hazard warning lights BUT they are still working????
rosieposie
Newbie
Newbie
 
Posts: 2
Joined: Mon Jul 29, 2019 9:23 am
Region: Midlands



Re: Inditcators not working

Postby JEOH on Thu Aug 08, 2019 11:54 pm

Had this with our 1995 Frontera:

Debris an dust went into the hazard indicator switch and caused a Gremlin - indicator out of function.
A pretty cleaning of the switch solved the problem.
Kind regards,
Ian

Sorry for my pigeonenglish.
Image
My doctor says I have to invest time in SPORT
User avatar
JEOH
How Many Posts
How Many Posts
 
Posts: 358
Joined: Thu Apr 22, 2010 12:10 am
Location: Germany - Freiburg area since 10-2017
Model: 2.0i Sport 3dr
Registration Year: 1995/N
Vehicle Name: Gigante & Grünstreifen
Modifications: EX-GODZILLA (1995) 2010-2018 RiP
G R Ü N S T R E I F E N (1997) 2013 - today:
BL 2.5 cm, roofrack scratch w cb,
stripped interior,
DEFA heater 230V DC + motorwarming
Cooper Disc AT3 Dim 235/70 R16
G I G A N T E (1998) 2018 - today:
General Grabber AT2, Soft-Top with
old engine (mix c20ne/s20xe) & gearbox donated by GodZilla
Region: International




Return to General discussion

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 4 guests

 
   


cron